Simple Login Log

Name: Simple Login Log
Type: XSS
Exploit version: 0.9.3
Release Date: 01-15-2013
Status: A new version of Simple Login Log has been released  •

Description:
1) Input passed via the "redirect_to" parameter and "User-Agent" HTTP header to wp-login.php is not properly sanitised before being used. This can be exploited to insert arbitrary HTML and script code, which will be executed in a user's browser session in context of an affected site if malicious data is viewed.

Successful unauthenticated exploitation requires the "Log Failed Attempts" setting to be enabled (disabled by default).

2) Input passed via the "where" GET parameter to wp-admin/users.php (when "page" is set to "login_log" and "download-login-log" is set to "true") is not properly sanitised before being used in a SQL query. This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

The vulnerabilities are confirmed in version 0.9.3. Prior versions may also be affected.

Plugin Information

  1. Downloaded: 52551 Times
  2. Current Version: 1.1.0
  3. Author: Profile
  4. Tested up to: 3.8.3
  5. Download Plugin

Security Information

  1. Secunia ID: 51780
  2. Credit: Vendor
  • Plugin statistics provided by WordPress.org. Updated within the last day or so.
  • ¹ Status info requires plugin author's to fill in versioning info on the wordpress.org repository